C3 Corvette Forum
http://corvettec3.com/cgi-bin/yabb2/YaBB.pl
Tech/Performance/Info >> Air Conditioning & Heating >> 80 blower- Hi or Non
http://corvettec3.com/cgi-bin/yabb2/YaBB.pl?num=1576052260

Message started by My80 on Dec 10th, 2019 at 11:59pm

Title: 80 blower- Hi or Non
Post by My80 on Dec 10th, 2019 at 11:59pm
Hi all, New here so hope I'm in the right spot. Ok blower speed problem for years. When key on Not even Low then only Hi. Replaced the resister twice thinking maybe defective. Replaced fan switch, replaced Relay. Now while trying to figure it out again my blower is making loud noise so ordered new blower motor with cage. Is there anything I am missing ? Thanks for any helpful suggestions :(

Title: Re: 80 blower- Hi or Non
Post by 68-73 on Dec 11th, 2019 at 9:26am
I'd have to see the wiring diagram, but I would suspect the motor after what you replaced. If Jack responds I would think he will have a good answer. I do know one thing grounds on these cars cause lots of problems so check for good grounds.
Alan [smiley=beer.gif]

Title: Re: 80 blower- Hi or Non
Post by Artsvettes on Dec 12th, 2019 at 6:36am
  Have to really think back on this one. I remember a change to the blower switch. They appear the same, but the contact count was different. One had one less contact. Which one for which year I don't remember. I also know the re-pop switches were garbage. Like Alan said check the ground
...jack 

C3 Corvette Forum » Powered by YaBB 2.5 AE!
YaBB Forum Software © 2000-2010. All Rights Reserved.